aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2020-03-24 20:51:06 +0100
committerAdrian Kummerlaender2020-03-24 20:51:06 +0100
commit235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a (patch)
tree184c2011b8e14149051c1fac1c7eaee282724d0d /shell.nix
parent955f517f3dc235c2abc96160da10787c1718e778 (diff)
downloadboltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.tar
boltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.tar.gz
boltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.tar.bz2
boltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.tar.lz
boltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.tar.xz
boltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.tar.zst
boltzgas-235123e65b5edb3d5f0c8f14b05e2d2e56f9e40a.zip
Separate classes into modules
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix3
1 files changed, 2 insertions, 1 deletions
diff --git a/shell.nix b/shell.nix
index d82cbe3..d2ea65e 100644
--- a/shell.nix
+++ b/shell.nix
@@ -37,7 +37,8 @@ pkgs.stdenvNoCC.mkDerivation rec {
shellHook = ''
export NIX_SHELL_NAME="${name}"
+ export PYTHONPATH="$PWD/boltzgas:$PYTHONPATH"
export PYOPENCL_COMPILER_OUTPUT=1
- export PYTHONPATH="$PWD:$PYTHONPATH"
+ export PYTHONDONTWRITEBYTECODE=1
'';
}