aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-12-15 23:09:32 +0100
committerAdrian Kummerlaender2018-12-15 23:09:32 +0100
commit44f5ac32a68a617f93704d44c4339f7db13b323e (patch)
tree6c191524aca1c7dbf3329026a59cfa3bc0109d2f /shell.nix
downloadcompustream-44f5ac32a68a617f93704d44c4339f7db13b323e.tar
compustream-44f5ac32a68a617f93704d44c4339f7db13b323e.tar.gz
compustream-44f5ac32a68a617f93704d44c4339f7db13b323e.tar.bz2
compustream-44f5ac32a68a617f93704d44c4339f7db13b323e.tar.lz
compustream-44f5ac32a68a617f93704d44c4339f7db13b323e.tar.xz
compustream-44f5ac32a68a617f93704d44c4339f7db13b323e.tar.zst
compustream-44f5ac32a68a617f93704d44c4339f7db13b323e.zip
Hacky D2Q9 BGK LBM on GPU using GLSL compute shaders
Improvised on top of computicles's scaffolding. Works in a world where _works_ is defined as "displays stuff on screen that invokes thoughts of fluid movement".
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..b457068
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,20 @@
+with import <nixpkgs> {};
+
+stdenvNoCC.mkDerivation rec {
+ name = "compustream-env";
+ env = buildEnv { name = name; paths = buildInputs; };
+
+ buildInputs = [
+ fish
+ git cmake
+ gcc8
+ gdb cgdb
+ glfw3
+ glew
+ glm
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
+}