aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..b457068
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,20 @@
+with import <nixpkgs> {};
+
+stdenvNoCC.mkDerivation rec {
+ name = "compustream-env";
+ env = buildEnv { name = name; paths = buildInputs; };
+
+ buildInputs = [
+ fish
+ git cmake
+ gcc8
+ gdb cgdb
+ glfw3
+ glew
+ glm
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
+}