summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-06-24 15:49:04 +0200
committerAdrian Kummerlaender2019-06-24 15:55:59 +0200
commit1477bbe177da4d3ad07877d4b672aac4828d0a13 (patch)
treefa001f2be8cd2606ef469f177cb71860db72ef5e /shell.nix
parentd316b74c25ea98d0145a9adad4ff9953f07581e4 (diff)
downloadgrid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.tar
grid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.tar.gz
grid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.tar.bz2
grid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.tar.lz
grid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.tar.xz
grid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.tar.zst
grid_refinement_openlb-1477bbe177da4d3ad07877d4b672aac4828d0a13.zip
Fix rebase conflictsHEADmaster
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..e5e5b52
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,45 @@
+{ pkgs ? import <nixpkgs> { }, ... }:
+
+pkgs.stdenvNoCC.mkDerivation rec {
+ name = "openlb-env";
+
+ env = pkgs.buildEnv {
+ name = name;
+ paths = buildInputs;
+ };
+
+ buildInputs = with pkgs; let
+ texlive-custom = texlive.combine {
+ inherit (texlive) scheme-small collection-langgerman latexmk xpatch xstring siunitx biblatex logreq palatino courier mathpazo helvetic multirow;
+ };
+ in [
+ # make dependencies
+ gnumake
+ gcc9
+ openmpi
+
+ # introspection
+ universal-ctags
+
+ # debugging
+ gdb
+ cgdb
+ valgrind
+
+ # autoformat
+ astyle
+
+ # result presentation
+ gnuplot
+
+ # documentation
+ doxygen
+ graphviz
+ texlive-custom
+ biber
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
+}