summaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix45
1 files changed, 45 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..e5e5b52
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,45 @@
+{ pkgs ? import <nixpkgs> { }, ... }:
+
+pkgs.stdenvNoCC.mkDerivation rec {
+ name = "openlb-env";
+
+ env = pkgs.buildEnv {
+ name = name;
+ paths = buildInputs;
+ };
+
+ buildInputs = with pkgs; let
+ texlive-custom = texlive.combine {
+ inherit (texlive) scheme-small collection-langgerman latexmk xpatch xstring siunitx biblatex logreq palatino courier mathpazo helvetic multirow;
+ };
+ in [
+ # make dependencies
+ gnumake
+ gcc9
+ openmpi
+
+ # introspection
+ universal-ctags
+
+ # debugging
+ gdb
+ cgdb
+ valgrind
+
+ # autoformat
+ astyle
+
+ # result presentation
+ gnuplot
+
+ # documentation
+ doxygen
+ graphviz
+ texlive-custom
+ biber
+ ];
+
+ shellHook = ''
+ export NIX_SHELL_NAME="${name}"
+ '';
+}