aboutsummaryrefslogtreecommitdiff
path: root/custom.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-02-22 20:34:18 +0100
committerAdrian Kummerlaender2019-02-22 20:34:18 +0100
commit4bda7bcd1eb2410ff7466fd4da2b5345ece6763f (patch)
tree167e374e350978c175747de0b7b522dc27543ae1 /custom.nix
parent0b2cde8591776d58333b07062748606d91a9f1db (diff)
downloadnixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.gz
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.bz2
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.lz
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.xz
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.tar.zst
nixos_home-4bda7bcd1eb2410ff7466fd4da2b5345ece6763f.zip
Declare tasks as attribute option
This way it is easy to support e.g. host specific tasks
Diffstat (limited to 'custom.nix')
-rw-r--r--custom.nix12
1 files changed, 9 insertions, 3 deletions
diff --git a/custom.nix b/custom.nix
index 266a37e..acc8f0e 100644
--- a/custom.nix
+++ b/custom.nix
@@ -1,8 +1,14 @@
{ pkgs, ... }:
{
- options.custom.hidpi = pkgs.lib.mkOption {
- type = pkgs.lib.types.bool;
- description = "Configure UI for high DPI displays";
+ options.custom = {
+ hidpi = pkgs.lib.mkOption {
+ type = pkgs.lib.types.bool;
+ description = "Configure UI for high DPI displays";
+ };
+
+ tasks = pkgs.lib.mkOption {
+ type = pkgs.lib.types.attrs;
+ };
};
}