aboutsummaryrefslogtreecommitdiff
path: root/gui/touchegg.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-02-15 22:27:32 +0100
committerAdrian Kummerlaender2019-02-15 22:27:32 +0100
commit18425fd98eae360ab4af07abe724658875e732ec (patch)
tree2d2db1a6a99cf9bcda4b902f51fbe0ddd697a06f /gui/touchegg.nix
parent5d9a1fbfb0ccab88a8e6e00cbe5e9f1dc06a915d (diff)
downloadnixos_home-18425fd98eae360ab4af07abe724658875e732ec.tar
nixos_home-18425fd98eae360ab4af07abe724658875e732ec.tar.gz
nixos_home-18425fd98eae360ab4af07abe724658875e732ec.tar.bz2
nixos_home-18425fd98eae360ab4af07abe724658875e732ec.tar.lz
nixos_home-18425fd98eae360ab4af07abe724658875e732ec.tar.xz
nixos_home-18425fd98eae360ab4af07abe724658875e732ec.tar.zst
nixos_home-18425fd98eae360ab4af07abe724658875e732ec.zip
Add custom script for cycling workspaces in touchegg
Diffstat (limited to 'gui/touchegg.nix')
-rw-r--r--gui/touchegg.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/gui/touchegg.nix b/gui/touchegg.nix
index 1455da8..fee4344 100644
--- a/gui/touchegg.nix
+++ b/gui/touchegg.nix
@@ -1,7 +1,23 @@
{ pkgs, ... }:
{
- home.file.".config/touchegg/touchegg.conf".source = ./conf/touchegg.conf;
+ home.file.".config/touchegg/touchegg.conf".lines = let
+ uictrl = pkgs.lib.callPackageWith pkgs ./pkgs/uictrl.nix { };
+ in ''
+ <touchégg>
+ <application name="All">
+ <gesture type="DRAG" fingers="3" direction="LEFT">
+ <action type="RUN_COMMAND">${uictrl}/bin/uictrl prev</action>
+ </gesture>
+ <gesture type="DRAG" fingers="3" direction="RIGHT">
+ <action type="RUN_COMMAND">${uictrl}/bin/uictrl next</action>
+ </gesture>
+ <gesture type="TAP" fingers="2">
+ <action type="MOUSE_CLICK">BUTTON=3</action>
+ </gesture>
+ </application>
+ </touchégg>
+ '';
systemd.user.services.touchegg = {
Unit = {