aboutsummaryrefslogtreecommitdiff
path: root/gui/touchegg.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gui/touchegg.nix')
-rw-r--r--gui/touchegg.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/gui/touchegg.nix b/gui/touchegg.nix
index 1455da8..fee4344 100644
--- a/gui/touchegg.nix
+++ b/gui/touchegg.nix
@@ -1,7 +1,23 @@
{ pkgs, ... }:
{
- home.file.".config/touchegg/touchegg.conf".source = ./conf/touchegg.conf;
+ home.file.".config/touchegg/touchegg.conf".lines = let
+ uictrl = pkgs.lib.callPackageWith pkgs ./pkgs/uictrl.nix { };
+ in ''
+ <touchégg>
+ <application name="All">
+ <gesture type="DRAG" fingers="3" direction="LEFT">
+ <action type="RUN_COMMAND">${uictrl}/bin/uictrl prev</action>
+ </gesture>
+ <gesture type="DRAG" fingers="3" direction="RIGHT">
+ <action type="RUN_COMMAND">${uictrl}/bin/uictrl next</action>
+ </gesture>
+ <gesture type="TAP" fingers="2">
+ <action type="MOUSE_CLICK">BUTTON=3</action>
+ </gesture>
+ </application>
+ </touchégg>
+ '';
systemd.user.services.touchegg = {
Unit = {