summaryrefslogtreecommitdiff
path: root/host/athena.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2022-01-26 23:36:57 +0100
committerAdrian Kummerlaender2022-01-26 23:58:08 +0100
commit8a9ed9adda26f00722a365bdcda17bb573d7a6c3 (patch)
treea762fc7b008ad3659bfe0d0b5bdce78262bdf9f9 /host/athena.nix
parentc7d90c505aefe8719a79baa04a97d2a7937e389c (diff)
downloadnixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.tar
nixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.tar.gz
nixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.tar.bz2
nixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.tar.lz
nixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.tar.xz
nixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.tar.zst
nixos_system-8a9ed9adda26f00722a365bdcda17bb573d7a6c3.zip
Update athena wireguard
Diffstat (limited to 'host/athena.nix')
-rw-r--r--host/athena.nix34
1 files changed, 17 insertions, 17 deletions
diff --git a/host/athena.nix b/host/athena.nix
index 6426bb9..1053c54 100644
--- a/host/athena.nix
+++ b/host/athena.nix
@@ -29,23 +29,23 @@
users.extraUsers.common.extraGroups = [ "networkmanager" "libvirtd" ];
- #networking.wireguard.interfaces = {
- # wg0 = {
- # ips = [ "10.100.0.4/24" ];
-
- # privateKeyFile = "/etc/wireguard/private";
-
- # peers = [
- # { # automatix
- # publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
- # allowedIPs = [ "10.100.0.0/24" ];
- # endpoint = "kummerlaender.eu:54321";
-
- # persistentKeepalive = 10;
- # }
- # ];
- # };
- #};
+ networking.wireguard.interfaces = {
+ wg0 = {
+ ips = [ "10.100.0.4/24" ];
+
+ privateKeyFile = "/etc/wireguard/private";
+
+ peers = [
+ { # automatix
+ publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
+ allowedIPs = [ "10.100.0.0/24" ];
+ endpoint = "kummerlaender.eu:54321";
+
+ persistentKeepalive = 10;
+ }
+ ];
+ };
+ };
services = {
upower.enable = true;