summaryrefslogtreecommitdiff
path: root/host/athena.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/athena.nix')
-rw-r--r--host/athena.nix34
1 files changed, 17 insertions, 17 deletions
diff --git a/host/athena.nix b/host/athena.nix
index 6426bb9..1053c54 100644
--- a/host/athena.nix
+++ b/host/athena.nix
@@ -29,23 +29,23 @@
users.extraUsers.common.extraGroups = [ "networkmanager" "libvirtd" ];
- #networking.wireguard.interfaces = {
- # wg0 = {
- # ips = [ "10.100.0.4/24" ];
-
- # privateKeyFile = "/etc/wireguard/private";
-
- # peers = [
- # { # automatix
- # publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
- # allowedIPs = [ "10.100.0.0/24" ];
- # endpoint = "kummerlaender.eu:54321";
-
- # persistentKeepalive = 10;
- # }
- # ];
- # };
- #};
+ networking.wireguard.interfaces = {
+ wg0 = {
+ ips = [ "10.100.0.4/24" ];
+
+ privateKeyFile = "/etc/wireguard/private";
+
+ peers = [
+ { # automatix
+ publicKey = "B0tkjq+5SfECKx1gWEP5JVWOIaRWL2JNE7iSpMmN4F0=";
+ allowedIPs = [ "10.100.0.0/24" ];
+ endpoint = "kummerlaender.eu:54321";
+
+ persistentKeepalive = 10;
+ }
+ ];
+ };
+ };
services = {
upower.enable = true;