summaryrefslogtreecommitdiff
path: root/host/automatix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-23 12:27:40 +0200
committerAdrian Kummerlaender2018-09-23 12:27:40 +0200
commit34b73e34e2d6a280264421663c7bce326c68f897 (patch)
tree2a36319ac54965b38f74094673f5f4efcc37e413 /host/automatix.nix
parent325e80caaaaa202a71bc1111d3e19a92d99e7ada (diff)
downloadnixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.gz
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.bz2
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.lz
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.xz
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.zst
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.zip
Restructure host config, derivations
Diffstat (limited to 'host/automatix.nix')
-rw-r--r--host/automatix.nix40
1 files changed, 4 insertions, 36 deletions
diff --git a/host/automatix.nix b/host/automatix.nix
index 9724b95..cbd0aeb 100644
--- a/host/automatix.nix
+++ b/host/automatix.nix
@@ -1,7 +1,10 @@
{ pkgs, ... }:
{
- imports = [ ./hardware/automatix.nix ];
+ imports = [
+ ./hardware/automatix.nix
+ ./software/code.kummerlaender.eu.nix
+ ];
boot.loader.grub = {
enable = true;
@@ -18,31 +21,6 @@
};
services = {
- gitea = {
- enable = true;
- database.type = "sqlite3";
-
- appName = "~/projects";
- domain = "code.kummerlaender.eu";
- rootUrl = "https://code.kummerlaender.eu/";
- httpPort = 3000;
-
- extraConfig = ''
- [server]
- LANDING_PAGE = "explore"
- [service]
- DISABLE_REGISTRATION = true
- SHOW_REGISTRATION_BUTTON = false
- [api]
- ENABLE_SWAGGER_ENDPOINT = false
- [picture]
- DISABLE_GRAVATAR = true
- [other]
- SHOW_FOOTER_VERSION = false
- SHOW_FOOTER_TEMPLATE_LOAD_TIME = false
- '';
- };
-
nginx = {
enable = true;
@@ -50,16 +28,6 @@
recommendedOptimisation = true;
recommendedProxySettings = true;
recommendedTlsSettings = true;
-
- virtualHosts."code.kummerlaender.eu" = {
- addSSL = true;
- enableACME = true;
- locations = {
- "/" = {
- proxyPass = "http://localhost:3000/";
- };
- };
- };
};
};
}