summaryrefslogtreecommitdiff
path: root/host/hardware/automatix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-21 17:49:51 +0200
committerAdrian Kummerlaender2018-09-21 17:49:51 +0200
commit0024a2ca7918be83ad812b02348cb49dd2ff2d57 (patch)
tree53e12738aa868fa7025083fd90df9ff0d524d8e9 /host/hardware/automatix.nix
parent7de3c3bee50247cd3a1102a5eab0d8ebb9ca0432 (diff)
downloadnixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.gz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.bz2
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.lz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.xz
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.tar.zst
nixos_system-0024a2ca7918be83ad812b02348cb49dd2ff2d57.zip
Add basic automatix config
Extract desktop-specific settings that are shared by asterix and obelix into desktop role.
Diffstat (limited to 'host/hardware/automatix.nix')
-rw-r--r--host/hardware/automatix.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/host/hardware/automatix.nix b/host/hardware/automatix.nix
new file mode 100644
index 0000000..4b35109
--- /dev/null
+++ b/host/hardware/automatix.nix
@@ -0,0 +1,25 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/profiles/qemu-guest.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "ata_piix" "uhci_hcd" "virtio_pci" "sd_mod" "sr_mod" ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/ec324e84-6766-49b7-ad5e-583e78a35432";
+ fsType = "ext4";
+ };
+
+ swapDevices =
+ [ { device = "/dev/disk/by-uuid/05f0315c-f5f5-4471-b2ef-6e53b95cb08b"; }
+ ];
+
+ nix.maxJobs = lib.mkDefault 1;
+}