summaryrefslogtreecommitdiff
path: root/host/majestix.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2021-08-23 13:30:46 +0200
committerAdrian Kummerlaender2021-08-23 13:38:25 +0200
commitdf1073ecb2c42eae043ab69a0b250caeea24731c (patch)
treed3a2877b9ad43ab0e3830cd54c40c57701de4287 /host/majestix.nix
parent171a2a7dc1bb5dceff2692baed0b552f663b8f3b (diff)
downloadnixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.tar
nixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.tar.gz
nixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.tar.bz2
nixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.tar.lz
nixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.tar.xz
nixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.tar.zst
nixos_system-df1073ecb2c42eae043ab69a0b250caeea24731c.zip
Add gitlab-runner to majestix
Diffstat (limited to 'host/majestix.nix')
-rw-r--r--host/majestix.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/host/majestix.nix b/host/majestix.nix
index 23cac16..f67d1b6 100644
--- a/host/majestix.nix
+++ b/host/majestix.nix
@@ -4,6 +4,7 @@
imports = [
./hardware/majestix.nix
./software/desktop
+ ./software/server/runner.nix
];
boot = {
@@ -27,7 +28,11 @@
networkmanager.enable = true;
};
- users.extraUsers.common.extraGroups = [ "networkmanager" ];
+ virtualisation.libvirtd.enable = true;
+ programs.dconf.enable = true;
+ environment.systemPackages = with pkgs; [ virt-manager ];
+
+ users.extraUsers.common.extraGroups = [ "networkmanager" "libvirtd" ];
services = {
acpid.enable = true;