summaryrefslogtreecommitdiff
path: root/host/majestix.nix
diff options
context:
space:
mode:
Diffstat (limited to 'host/majestix.nix')
-rw-r--r--host/majestix.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/host/majestix.nix b/host/majestix.nix
index 23cac16..f67d1b6 100644
--- a/host/majestix.nix
+++ b/host/majestix.nix
@@ -4,6 +4,7 @@
imports = [
./hardware/majestix.nix
./software/desktop
+ ./software/server/runner.nix
];
boot = {
@@ -27,7 +28,11 @@
networkmanager.enable = true;
};
- users.extraUsers.common.extraGroups = [ "networkmanager" ];
+ virtualisation.libvirtd.enable = true;
+ programs.dconf.enable = true;
+ environment.systemPackages = with pkgs; [ virt-manager ];
+
+ users.extraUsers.common.extraGroups = [ "networkmanager" "libvirtd" ];
services = {
acpid.enable = true;