summaryrefslogtreecommitdiff
path: root/host/software/vim.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2018-09-23 12:27:40 +0200
committerAdrian Kummerlaender2018-09-23 12:27:40 +0200
commit34b73e34e2d6a280264421663c7bce326c68f897 (patch)
tree2a36319ac54965b38f74094673f5f4efcc37e413 /host/software/vim.nix
parent325e80caaaaa202a71bc1111d3e19a92d99e7ada (diff)
downloadnixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.gz
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.bz2
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.lz
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.xz
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.tar.zst
nixos_system-34b73e34e2d6a280264421663c7bce326c68f897.zip
Restructure host config, derivations
Diffstat (limited to 'host/software/vim.nix')
-rw-r--r--host/software/vim.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/host/software/vim.nix b/host/software/vim.nix
new file mode 100644
index 0000000..8bd9b7f
--- /dev/null
+++ b/host/software/vim.nix
@@ -0,0 +1,9 @@
+{ pkgs, ... }:
+
+{
+ environment.systemPackages = let
+ custom_vim = import ./pkgs/vim/default.nix pkgs;
+ in [
+ custom_vim
+ ];
+}