summaryrefslogtreecommitdiff
path: root/pkgs/custom-neovim/default.nix
diff options
context:
space:
mode:
authorAdrian Kummerlaender2019-03-03 20:28:46 +0100
committerAdrian Kummerlaender2019-03-03 20:28:50 +0100
commita9ceae32286b080797e92fe4725ea1280fbc85d9 (patch)
treeb0a00c6f5b9b89af115ccf4fcf3983cd217b3563 /pkgs/custom-neovim/default.nix
parent74ed6df47cc880f0c77cb32ebe0b80211287b331 (diff)
downloadpkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.tar
pkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.tar.gz
pkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.tar.bz2
pkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.tar.lz
pkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.tar.xz
pkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.tar.zst
pkgs-a9ceae32286b080797e92fe4725ea1280fbc85d9.zip
Restructure vim configuration
* Use integrated plugin manager * Switch to nvim instead of continuing to maintain a config for both vims
Diffstat (limited to 'pkgs/custom-neovim/default.nix')
-rw-r--r--pkgs/custom-neovim/default.nix51
1 files changed, 48 insertions, 3 deletions
diff --git a/pkgs/custom-neovim/default.nix b/pkgs/custom-neovim/default.nix
index 34e2fcd..8568c08 100644
--- a/pkgs/custom-neovim/default.nix
+++ b/pkgs/custom-neovim/default.nix
@@ -1,6 +1,51 @@
{ pkgs, ... }:
-pkgs.neovim.override {
- vimAlias = false;
- configure = import ../custom-vim/custom.nix { pkgs = pkgs; };
+let
+ plugins = pkgs.callPackage ./plugins.nix {};
+
+in pkgs.neovim.override {
+ vimAlias = true;
+ configure = {
+ customRC = builtins.readFile ./asset/rc.vim;
+
+ packages.myVimPackage = with pkgs.vimPlugins // plugins; {
+ start = [
+ # UI enhancements
+ airline
+ goyo
+
+ # autocomplete
+ LanguageClient-neovim
+ deoplete-nvim
+
+ # load project specific config
+ vim-localvimrc
+
+ # colors, syntax highlighting
+ vim-color-akr
+ vim-polyglot
+ vim-addon-nix
+
+ # file, buffer management
+ ctrlp
+ vim-counterpoint
+ vim-signature
+
+ # undo history tree
+ vim-mundo
+
+ # editing enhancements
+ vim-unimpaired
+ vim-wordmotion
+ vim-autoformat
+ vim-sandwich
+ far
+
+ # git integration
+ vim-gitgutter
+ gina
+
+ ];
+ };
+ };
}