summaryrefslogtreecommitdiff
path: root/pkgs/custom-neovim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/custom-neovim/default.nix')
-rw-r--r--pkgs/custom-neovim/default.nix51
1 files changed, 48 insertions, 3 deletions
diff --git a/pkgs/custom-neovim/default.nix b/pkgs/custom-neovim/default.nix
index 34e2fcd..8568c08 100644
--- a/pkgs/custom-neovim/default.nix
+++ b/pkgs/custom-neovim/default.nix
@@ -1,6 +1,51 @@
{ pkgs, ... }:
-pkgs.neovim.override {
- vimAlias = false;
- configure = import ../custom-vim/custom.nix { pkgs = pkgs; };
+let
+ plugins = pkgs.callPackage ./plugins.nix {};
+
+in pkgs.neovim.override {
+ vimAlias = true;
+ configure = {
+ customRC = builtins.readFile ./asset/rc.vim;
+
+ packages.myVimPackage = with pkgs.vimPlugins // plugins; {
+ start = [
+ # UI enhancements
+ airline
+ goyo
+
+ # autocomplete
+ LanguageClient-neovim
+ deoplete-nvim
+
+ # load project specific config
+ vim-localvimrc
+
+ # colors, syntax highlighting
+ vim-color-akr
+ vim-polyglot
+ vim-addon-nix
+
+ # file, buffer management
+ ctrlp
+ vim-counterpoint
+ vim-signature
+
+ # undo history tree
+ vim-mundo
+
+ # editing enhancements
+ vim-unimpaired
+ vim-wordmotion
+ vim-autoformat
+ vim-sandwich
+ far
+
+ # git integration
+ vim-gitgutter
+ gina
+
+ ];
+ };
+ };
}